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前    言 

CATIA（Computer Aided Tri-Dimensional Interface Application）缩写。是法国 Dassault
公司开发的 CAD/CAE/CAM 一体化软件。广泛应用于航空航天、汽车制造、造船、机

械制造、电子\电器、消费品行业，它的集成解决方案覆盖所有的产品设计与制造领域，

其特有的 DMU 电子样机模块功能及混合建模技术更是推动着企业竞争力和生产力的提

高。CATIA 提供方便的解决方案，迎合所有工业领域的大、中、小型企业需要。CATIA 
V5 版本是 IBM 和达索系统公司长期以来在为数字化企业服务过程中不断探索的结晶。

围绕数字化产品和电子商务集成概念进行系统结构设计的 CATIA V5 版本，可为数字化

企业建立一个针对产品整个开发过程的工作环境。在这个环境中，可以对产品开发过程

的各个方面进行仿真，并能够实现工程人员和非工程人员之间的电子通信。产品整个开

发过程包括概念设计、详细设计、工程分析、成品定义和制造乃至成品在整个生命周期

中的使用和维护。CATIA V5 版本具有：重新构造的新一代体系结构、支持不同应用层

次的可扩充性、与 NT 和 UNIX 硬件平台的独立性 、专用知识的捕捉和重复使用、给现

存客户平稳升级等功能。 
本书以 CATIA V5R16 为平台，共分 16 个章节。以初学者为中心编著。前面内容主

要是三维设计的基础，之后是高级内容，最后是应用 DMU 和变量建模的方法。对于初

学者，可以先从简单的实例开始，体会一下 CATIA 软件的功能。有一定的了解之后，再

系统学习高级篇。CATIA 软件功能强大，涉及到机械设计、电子产品设计、工厂布局等

领域。 
感谢您选择了本书，书中难免有疏漏之处，望您提出宝贵意见。 
 

编  者 

2008 年 5 月 
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第 1 章  CATIA V5 用户界面 

1．开始 

¤ 启动 CATIA V5 后（双击 ），其用户界面如图 1-1 所示，主要由工作窗口、菜

单栏、工具栏和命令行等组成。 

菜单栏 

工具栏 

命令栏 
工作窗口 

 

图 1-1 

2．选择 Workbench 

¤ 选择 Workbench 的四种方法。 
（1）选择菜单中的 Start，然后选择所需的 Workbench。 
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图 1-2 

（2）选择窗口下面的“New”图标 。 

 

图 1-3 

（3）选择菜单 Tools → Customize，对话框中用箭头选择常用的 Workbench（图 1-4）。 
（4）下次打开 CATIA 时，出现如下窗口，选择 Workbench 后直接进入（图 1-5）。 
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图 1-4 

 

图 1-5 
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3．Exit 

¤ 结束 CATIA V5 的命令。 
（1）选择菜单 Start → Exit； 
（2）选择窗口右上角的 键。 

4．New 

¤ 新建文档和修改过程中生成新的模型。 
（1）选择菜单 Start → New（Ctrl + N）； 
（2）选择窗口下面的“New”图标 。 

5．Open 

¤ 打开已有文档的命令。 
（1）选择菜单 Start → Open（Ctrl + O）； 
（2）选择窗口下面的“Open”图标  。 

6．Save 

¤ 保存新文档或修改的文档。 
（1）选择菜单 Start → Save（Ctrl + S）； 
（2）选择窗口下面的“Open”图标 。 

 
 

- Part Design, etc.: *.CATPart 
- Assembly     : *.CATProduct 
- Analysis      : *.CATAnalysis 

7．Save As 

¤ 按用户指定的方式保存文档，选择菜单 Start → Save As。 

8．Undo,Redo 

¤ 取消已实行的命令。 
（1）选择窗口下面的“Undo”图标  或 Ctrl + Z。 
（2）相反时，按 Redo  或 Ctrl + Y。 
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9．Fit All In 

¤ 显示最佳状态的命令，生成模型或打开文档后，显示位置不佳时，除放大功能外

常用的命令，选择窗口下面的“Fit All In”图标 。 

10．Pan 

¤ 任意移动模型的键，选择窗口下面的“Pan”图标 。 

11．Rotate 

¤ 任意旋转模型的键，选择窗口下面的“Rotate”图标 。 

12．Zoom 

¤ 放大、缩小模型的键，选择窗口下面的“Zoom In” 图标  或 “Zoom Out” 
图标 。 

13．Setting 

¤ 定义开始页面或菜单的命令。 
（1）菜单中选择 Tools → Customize 后，定义 CATIA 的开始页面。 

 

图 1-6 

（2）选择 Customize Box → Commands，定义菜单。 
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图 1-7 

14．Option 

¤ 定义页面和变量的命令。 
（1）菜单中选择 Tools → Option，General 中设定一般的事项。 

 

图 1-8 
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（2）选择 Option Box 中的 General → Parameters and measure，设定 Constraints 和
Dimensions。 

 

图 1-9 

（3）选择 Option Box 中的 General → Display ，设定页面颜色等。 

 

图 1-10 
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（4）选择 Option Box 中的 Mechanical Design → Drafting，设定视图项目等。 

 

图 1-11 

15．鼠标的使用方法 

（1）左键：选择与操作； 
（2）中键：按住的状态下移动鼠标时，模型会随着鼠标光标的移动而移动； 
（3）右键：模型或图标中点击时，可使用属性命令； 
（4）按住中键的状态下，按住右键（或左键）时，可旋转模型； 
（5）按住中键的状态下，点一下右键（或左键）时，可缩放模型； 
（6）双击命令时，可继续使用该功能。 

16．快捷键 

（1）Esc   ：退出当前对话框； 
（2）Shift + F1 ：得到工具栏按钮帮助； 
（3）Shift + F2 ：切换树形图预览； 
（4）F3   ：隐藏树形图； 
（5）Alt + F3  ：运行宏； 
（6）Shift + F3 ：锁定与激活模型轮廓位置； 
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（7）Ctrl + Page Up ：放大模型； 
（8）Ctrl + Page Down ：缩小模型； 
（9）Ctrl + ↑  ：向上平移模型； 
（10）Ctrl + ↓  ：向下平移模型； 
（11）Ctrl + ←  ：向左平移模型； 
（12）Ctrl + →  ：向右平移模型； 
（13）Ctrl + Tab  ：切换当前工作模型窗口。 



 

第 2 章  Sketcher 

1．开始 

¤ Sketcher，生成三维模型的界面。 
选择菜单中 Start → Mechanical Design → Part Design 

 

图 2-1 

2．选择作业平面 

¤ 选择作业平面的三种方法。 
（1）在 Specifications Tree 的 xy Plane，yz Plane，zx Plane 中任选一个，然后按右侧

工具栏中的“Sketcher” 。 
（2）在页面中央三个平面中任选一个，然后按右侧工具栏中的 Sketcher 。 



 

（3）把 Sketcher  图标拖到中央三维坐标中的任一个平面当中。 

3．Line 

¤ 进入 Sketcher 后，生成线条的命令。 
（1）选择右侧的 Line ，用鼠标选择适当的位置为起点和终点。 
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图 2-2 

（2）用鼠标左键选择线后，可以移动。如图 2-2 时，必须删除中心点和线的约束（选

择图中两个圆圈后，删除）。 
（3）用鼠标的左键双击线时，出现 Line Definition Box，对话框中可以调整线的属性。 

 

图 2-3 

4．Point 

¤ 用鼠标生成任意的一个点。 
（1）选择右侧的 Point ，用鼠标选择适当的位置后点击，用左键双击点时，出现

Point Definition Box，可修改点的坐标。 
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图 2-4 

（2）点击 Point  右下侧的倒三角形后，选择 Point by Using Coordinates  ，出

现 Point Definition Box，可设定点的坐标。 

 

图 2-5 

（3）对话框的 Cartesian 中输入 H=40mm，V=50mm 时，从中心点开始按 H 方向 40mm，

V 方向 50mm 的位置上生成一点。 

 

图 2-6 
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（4）对话框的 Polar 中输入 Radius=50mm，Angle=45°时，从中心点开始半径为

50mm，与 H 轴 45°的位置上生成一点。 
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图 2-7 

（5）生成相同距离点的命令，Equidistant Point 。先生成一条线后选择 ，出现

Equidistant Point Definition Box，用鼠标点击线的一端，然后输入适当的值后按 OK 键。 

 

图 2-8 

界面中生成了间隔为 25mm 的 4 个点。选择一端后按对话框下面的 Reverse Direction
时，按反方向生成。 

5．Circle 

¤ 生成圆的命令，Circle 。 
（1）画一个圆后双击该圆，出现 Circle Definition Box。如图 2-9 输入数据时生成圆

心坐标为（0，0），半径为 25mm 的圆。 
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图 2-9 

（2）点击图标下方的倒三角形，选择 Three Point Circle ，依次选择三个点。 
（3）用一个点和半径来画圆 。选择图标后出现如下对话框，输入中心坐标为（0，

0），半径为 25mm 时，生成如图 2-10。 

 

图 2-10 

（4）选择 Polar，按下图输入数据后，生成 H=50mm，V=45mm，Radius=20mm 的圆。 
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图 2-11 

（5）生成椭圆的命令 Ellipse  。选择图标后，依次选择三个点，生成如下椭圆。

第一个点是中心点、第二个点是长轴、第三点是短轴。 

 

图 2-12 

（6）用三点生成圆弧的命令 Three Point Arc 。依次选三点生成圆弧。 
（7）利用一点和半径画圆弧的命令 Arc 。 

6．Rectangles 

¤ 生成矩形的命令 Rectangles 。 
（1）生成矩形，双击后可修改。 
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图 2-13 

（2）点击 右下方倒三角形后，选择生成任意方向的矩形，Oriented Rectangle 。 
（3）生成平行四边形的命令，Parallelogram 。 
（4）生成椭圆的命令 Oblong Profile 。 
* Profile – 一笔画出的有约束的图形轮廓。

（5）生成圆柱形延长孔的命令 Curved Oblong Profile 。 
（6）生成钥匙孔形的命令 Keyhole Profile 。 

7．Hexagon 

¤ 生成六角形的命令 Hexagon ，生成六角形后，双击。在 Line Definition Box
如图 2-14 形成起点为坐标中心，边长为 30mm 的六角形。 

 

图 2-14 

8．Spline 

¤ 生成曲线的命令 Spline 。 
* 画Spline时，尽量避免各点之间产生约束。产生约束时，点变红色，点之间自动生

 16



 

成蓝色的虚线。

9．Axis 

¤ 旋转模型时的中心轴 Axis 。 

10．Profile 

¤ 连续画图形的命令，Profile 。如图 2-15，先画一个轴线，然后点击  键，

向右、向上画直线后按住左键的同时向左拖鼠标，生成孤。之后向上、向左画直线，与轴

线相交。 
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* 在窗口的右方或下方工具栏中找不到需要的命令图标时，用鼠标点击命令框上面

的横线部分后，拖到操作界面中。 
* 鼠标放在右侧或下方工具栏中，点击右键后查询。 

 

图 2-15 

11．Corner 

¤ 生成倒角的命令，Corner  键。图 2-15 中，点击  键后选择上面两条直线，

生成倒角。双击倒角后，可设定其值（见图 2-16）。 
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图 2-16 

12．Chamfer 

¤ 生成倒角的命令，Chamfer  键。图 2-16 的右下角画一个倒角（与倒角的操

作法相同）。 

 

图 2-17 
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13．Dimensional Constrains 

¤ 以对话框形式定义约束的命令，Dimensional constrains  键。图 2-17 中点击 
 键后，把大圆的半径设为 35mm（见图 2-18）。相同的方法来可以约束轴与其他线。 
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图 2-18 

14．Creating a Symmetry 

¤ 生成对称图形命令，Creating a Symmetry  键。图 2-18 中选择轴以上的图形，

然后点击  键，再点击轴线。 

 

图 2-19 
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15．Trim 

¤ 对某些部分进行修剪的命令，Trim 。 
（1）画出图 2-20。 

 

图 2-20 

（2）点击  键后，选择三角形左下方的线，再选三角形内部的线（见图 2-21）。 

 

图 2-21 

（3）用相同的方法把右侧也进行修剪（见图 2-22）。 
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图 2-22 

16．Break 

¤ 对某些部分进行打断的命令，Break （点击  右下方倒三角形）。 
（1）画出图 2-23。 

 

图 2-23 

（2）点击  键后选择左斜线，然后选中间的水平线。斜线被打断成两部分，删除

斜线左下部分（见图 2-24）。 

 

图 2-24 
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第 3 章  Part Design 

1．开始 

¤ Sketcher，生成三维模型的界面。 
（1）选择菜单中 Start → Mechanical Design → Part Design。 
（2）选择 xy Plane → Sketcher（ ）后，用 Profile 画图形如图 3-1。 

 

图 3-1 

2．Pad 

¤ 生成厚度的命令，Pad 。 
（1）点击 Exit Workbench  后，选择 。出现 Pad Definition Box，设长度为 40mm

后点击 OK 键（见图 3-2）。 

               

图 3-2                                    图 3-3 



 

（2）整个图形的生成过程在 Sketch Plane 中按垂直方向显示（如图 3-4）。 
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图 3-4 

（3）点击上图中左内侧，点击 键，进入 Sketcher 界面，画一个圆后点击 ，点击

，输入长度为 40mm，点击 OK 键（见图 3-5）。双击圆柱后，输入长度为 80mm，点

击 OK 键（见图 3-6）。 

              

图 3-5                                   图 3-6 

（4）Pad Definition 中 Type 的说明。 

 

图 3-7 

① Dimension - 按指定长度； 
② Up To Next - 选择下一个面为止； 
③ Up To Last - 最后一个面为止； 
④ Up To Plane - 指定的平面为止； 
⑤ Up To surface - 指定的表面为止。 

3．Pocket 

¤ 三维模型中减重的命令，Pocket 。 
（1）用 xy plane Profile → Pad 命令设计如下图形（见

图 3-8）。 
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图 3-8 

（2）选择上一面，进入 Sketcher 后，用 Circle 画一个圆（见图 3-9）。 

 

图 3-9 

（3）点击 后，进入 Sketcher 界面，再点击 （见图 3-10）。 

 

图 3-10 

（4）点击 OK 键后，在垂直方向生成了一个孔（见图 3-11）。 
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图 3-11 

* Edition the Pad，Pocket（修改厚度和颜色） 
- 用鼠标双击模型的上一面或孔（在 specification tree 中也可以修改）； 
- Definition 对话框中长度输入 90mm 后，按 OK 键； 
- 在 Edit → Properties → Graphic tab→fill 中选择颜色，Transparency 中调整透明

度。 

4．Draft Angle 

¤ 生成拔模的命令，Draft Angle  。 
（1）用 xy plane Profile → Circle → Pad 命令设计如下图形（见图 3-12），点击 Draft 

Angle 键后，出现对话框（见图 3-13）。 

         

图 3-12                                  图 3-13 

（2）Angle 中输入 10°，鼠标放到 face(s) to draft 栏后，在模型中选择圆柱面，鼠标
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放到 Neutral Element → Selection 栏后，在模型中选择圆柱的上（或下）面（见图 3-14）。 

 

图 3-14 

（3）点击 OK 键后形成斜角为 10°的一个椎体（见图 3-15）。 

 

图 3-15 

5．Shaft 

¤ 旋转模型的命令，Shaft 。 
（1）用 Profile 画中心线和如下图形后（见图 3-16），点击  键。 
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图 3-16 

（2）点击 Shaft （见图 3-17）。 

 

图 3-17 

（3）First Angle 中输入 270°后，点击 OK 键，生成图形如图 3-18。 

 

图 3-18 
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6．Filleting an Edge 

¤ 模型的角上生成倒圆角的命令， 。 
（1）用 xy plane Profile → Pad 命令设计如下图形（见图 3-19）。 

 

图 3-19 

（2）点击 键（见图 3-20）。 

 

图 3-20 

（3）Radius 输入 10mm，鼠标放到模型中一个角的高度线后双击，Object(s) to fillet
自动输入该面的属性，然后点击 OK 键，生成一个半径为角的 10mm 倒圆（见图 3-21）。 

 

图 3-21 
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7．Variable Radius Fillets 

¤ 生成变半径倒角的命令，Variable Radius Fillets  （点击  右下角的倒三

角形） 
（1）用 xy plane Rectangle → Pad 命令生成如下图形后，点击  键（见图 3-22）。 
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图 3-22 

（2）Radius 输入 30mm，鼠标放到 Edge(s) to fillet 栏后，点击一个角（见图 3-23）。 

 

图 3-23 

（3）一个角的两侧出现半径尺寸标注，用鼠标双击其中一个尺寸（见图 3-24）。 
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图 3-24 

（4）Value 中输入 30mm 后，点击 OK 键。然后在 Variable Radius Fillet Definition Box
中点击 OK 键（见图 3-25）。 

 

图 3-25 

8．Face-Face Fillets 

¤ 生成面与面倒角的命令，Face-Face Fillets （点击  右下角的倒三角形）。 
（1）用 xy plane Rectangle → Pad → Circle → Pad → Draft Angle 画如下图（见图

3-26）。 
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图 3-26 

（2）点击  后，Radius 设 5mm，用鼠标选择四方形的上一面，再选择圆锥形的侧

面，然后点击 OK 键（见图 3-27）。 

 

图 3-27 

（3）Radius 值过大，发生干涉时的情况（见图 3-28）。 

 

图 3-28 
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9．Tritangent Fillets 

¤ 生成三面倒角的命令，Tritangent Fillets 。 
（1）用 xy palne Profile → Pad 画如下图形后（宽度设为 20mm，见图 3-29，图 3-30）。 

          

图 3-29                                图 3-30 

（2）点击 Edge Fillet 后，选择内直角的高度线，Radius 设 10mm。再选 Edge Fillet
后，选择外直角的高度线，Radius 设 30mm，点击 OK 键（见图 3-31）。 

 

图 3-31 

* 设倒角后，倒角处理部分与其他宽度要相同。 
（3）点击 （见图 3-32）。 

 

图 3-32 
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（4）鼠标选择 faces to fillet 后，点击模型中的内侧面、再按外侧面，Face To remove
中选择上一面之后，点击 OK 键（见图 3-33）。 
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图 3-33 

10．Mirroring the Part 

¤ 生成对称模型的命令，Mirroring the Part 。 
（1）用 xy plane Profile 画如下图形（见图 3-34，图 3-35）。 

        

图 3-34                                       图 3-35 

（2）点击 后，Mirroring element 栏中选择模型中的前一个面（见图 3-36）。 

 

图 3-36 

（3）点击 OK 键（见图 3-37）。 
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图 3-37 

11．Creating and Positioning a Hole 

¤ 模型中直接生成孔的命令，Creating and Positioning a Hole 。 
（1）上面模型中（见图 3-37）点击 键后，用鼠标在适当位置上点击（见图 3-38）。 

 

图 3-38 

（2）设坐标、直径和深度后，点击 OK 键（见图 3-39）。 
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图 3-39 

12．Shelling the Part 

¤ 抽壳功能是可以按照一定的规则将实体内部掏空，Shelling the Part 。 
（1）用 xy plane → sketcher → Circle → Pad 画如下图形（见图 3-40）。 

 

图 3-40 

（2）点击 键，出现如下对话框（见图 3-41）。 

 

图 3-41 
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（3）设厚度为 1mm，face to remove 栏中选择模型中的上一面，点击 OK 键，产生如

图 3-42。 

 

图 3-42 

13．Chamfer 

¤ 在模型的边角中生成倒梭的命令，Chamfer 。 
（1）画如下图形（见图 3-43）。 

 

图 3-43 

（2）点击 键，选择厚度，Object(to)Chafer 栏中用鼠标选择一个边角线（见图 3-44）。 

 

图 3-44 
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（3）点击 OK 键，产生如图 3-45。 
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图 3-45 

3.3.14  Pattern 

¤ 模式的命令，Pattern 。可按矩形、圆形和自定义模式进行复制。 
（1）用 xy plane → Sketcher → Rectangle → Exit → Pad → Circle → Pocket 画

如下图后，点击 键（见图 3-46）。 

 

图 3-46 

（2）对话框的 Instants 和 Spacing 中输入适当的值（4 和 28mm），见图 3-47。 
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图 3-47 

（3）Reference element 中用鼠标选择四方形的前一面，Object 中用鼠标选择模型中

的孔，点击 OK 键（见图 3-48）。 

 

图 3-48 

（4）按同样的方法，在 Second Direction 中，输入适当的 Instants(6)和 Spacing(30mm)
值，Reference element 中用鼠标选择下图中四方形的下面，Object 中用鼠标选择模型中

的 4 个孔，点击 OK 键（见图 3-49）。 

 

图 3-49 
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* 按对话框中的 Preview 时可以预览，根据预览结果可调整设定值。 
（5）按圆形模式生成的方法，用 Circle → Pad → Circle → Pad 命令画如图 3-50

后，点击 Circular Pattern （点击 右下角的倒三角形）。 
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图 3-50 

（6）设 Instance(8),Angular spacing(45)，Reference element 栏中用鼠标点击圆盘的上

一面，Object 栏中用鼠标点击小圆柱（见图 3-51）。 

 

图 3-51 

（7）点击 OK 键，产生如图 3-52。 
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图 3-52 

15．Rib 

¤ 按一定的轨道生成肋骨的命令，Rib 。 
（1）用 Rectangle → Pad 功能画如图 3-53。 

 

图 3-53 

（2）在四方形的上一面画一条 Spline 线（见图 3-54），然后点击 （见图 3-55）。 

        

图 3-54                                      图 3-55 
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（3）选择与 Spline 线垂直的面之后，点击 ，在 Spline 线的一端画一个圆（见图

3-56）。 
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图 3-56 

（4）点击  键后，点击 （见图 3-57）。 

 

图 3-57 

（5）对话框的 Profile 栏中用鼠标选择圆，Center curve 栏中用鼠标选择 Spline 后，

点击 OK 键，产生如图 3-58。 

 

图 3-58 
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16．Slot 

¤ 按一定的轨道开槽的命令，Slot 。 
（1）画到 Rib 步骤的第二阶段后，点击  键后（见图 3-55），点击 （见图 3-59）。 

 

图 3-59 

（2）对话框的 Profile 栏中用鼠标选择圆，Center curve 栏中用鼠标选择 Spline 后，

点击 OK 键，产生如图 3-60。 

 

图 3-60 

17．Stiffener 

¤ 按一定的轨道生成加强肋的命令，Stiffener （点击  右下方倒三角形）。 
（1）xy plane → Profile → Pad（用 Mirrored extent）画如图 3-61。 
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图 3-61 

（2）进入 xy plane 后，画一个 Profile，用 Mirrored extent（见图 3-62，3-63）。 

            

图 3-62                             图 3-63 

（3）点击 键（见图 3-64）。 

 

图 3-64 
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（4）Thickness 设为 10mm，Selection 栏中用鼠标选择 Spline 后，点击 OK 键，产生

如图 3-65。 

 

图 3-65 

18．Creating Plane 

¤ 作业平面上再生成一个平面的命令，Plane 。 
（1）用 Rectangle → Pad 画如下图后，点击 （见图 3-66）。 

 

图 3-66 

（2）Plan type 中选择 Angle to Plane，Rotation axis 选边线，Reference 选一面，Angle
设为 60°（见图 3-67）。 
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图 3-67 

（3）点击 OK 键，产生如图 3-68。 

 

图 3-68 

（4）用 Offset from plane 生成平面。画到第一步后，在 Plan type 中选择 Offset from 
plane，Reference 选一面，Offset 设为 30mm（见图 3-69）。 

 

图 3-69 

 45



 
CATIA V5 实用教程 

（5）点击 OK 键，产生如图 3-70。 

 

图 3-70 

19．Groove 

¤ 旋转沟槽的命令，Groove 。 
（1）用 yz plane → Profile → Pad 画如图 3-71。 

 

图 3-71 

（2）上面画中央一个垂直轴线后用 Mirrored Extent 功能画如图 3-72，3-73。 
 
 
 

 46



 

   

第3

章  Part D
esign

 

图 3-72                              图 3-73 

（3）选择一个面后点击  ，用 Profile 画一个图形（见图 3-74）。 

 

图 3-74 

（4）点击  后，点击  键。对话框的 Profile/Surface Selection 中用鼠标选 Profile，
Axis Selection 栏中用鼠标选模型中央的 Y 轴线，点击 OK 键，产生如图 3-75。 

 

图 3-75 
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20．Reordering Features 

¤ 生成 Part 的命令顺序发生变化时的命令 
（1）用 Rectangle → Pad 命令画图如图 3-76 后，向右侧 Mirror（见图 3-77）。 

          

图 3-76                         图 3-77 

（2）用 Circle → Pad 生成如图 3-78。 

 

图 3-78 

（3）窗口左侧 Tree 中选择 Pad2 后（见图 3-79），按鼠标的右键选择 Pad2.object → 
Reorder（见图 3-80）。 

                

图 3-79                            图 3-80 
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（4）左侧 Tree 中 Pad2 和 Mirror.1 的顺序发生了变化。按右键选择 Mirror.1 object → 
Deactivate。再按右键选择 Mirror.1 object → activate（见图 3-81）。 
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图 3-81 

* Pad2 命令比 Mirror.1 命令在先时使用该功能。 

21．Named Views 

¤ 显示指定的方向生成视图的命令  （点击窗口下方工具条中  右下方倒三

角形）。把模型调整到适当的方向后，设置 Named View（输入了 abc）。进行其他操作时，

点击  后，选择 abc 时显示当时设定的视图（见图 3-82）。 

 

图 3-82 

22．Title Horizontally，Title Vertically 

¤  同时显示多个窗口时的命令。打开三个文档后，选择 Window →  Title 
Horizontally 时，按水平方向同时显示三个窗口。选择 Window → Title Vertical 时，按

垂直方向同时显示三个窗口（见图 3-83）。 
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图 3-83 

23．Isometric View 

¤ 选择视图方式的命令（点击窗口下方工具条中  右下方倒三角形后，出现如

下工具条 ，可选择前视图、后视图、左视图、右视图等）。 

24．实例 Part Ⅰ 

（1）用 yz plane → Sketcher → Hexagon 画图如 3-84。用 constraint  设定尺寸

后，点击  。 

 

图 3-84 
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* 设定尺寸时，先删除一些画六角形时自动生成的尺寸约束； 
* 方向用对话框中的 Reverse Direction 选择。 
（2）点击  后，长度设为 50mm（见图 3-85）。 
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图 3-85 

（3）选择 yz plane（按模型的前部）后，进入 Sketcher。用 Circle 画如图 3-86（设圆

的直径为 15mm）。 

 

图 3-86 

（4）点击  。点击  后，长度设为 50mm（见图 3-87）。 
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图 3-87 

（5） 选择按圆柱的前部后，进入Sketcher。用Circle画如图 3-88，设圆的直径为 10mm。

点击  后，深度设为 10 mm，点击 OK 键。 

 

图 3-88 

（6）选择六角形的背面后进入 Sketcher ，用 Hexagon 画如图 3-89。用 constraint  
设定尺寸。 

 

图 3-89 
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（7）点击  。选择  后，深度设为 5mm。按鼠标右键，在 Properties 中选择适

当的颜色（见图 3-90）。 
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图 3-90 

25．实例 Part Ⅱ 

（1）用 xy plane → Sketcher → Profile 画如图 3-91。用 constraint  设定尺寸后，

点击  。 

 

图 3-91 

（2）点击  后，长度设为 100mm（见图 3-92）。 

 

图 3-92 

（3）选择模型的上面后，Sketcher → Profile 画如图 3-93，用 constraint  设定尺

寸后，点击 。 
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图 3-93 

（4）选择  后，深度设为 Up to last（见图 3-94）。 

 

图 3-94 

（5）选择被挖出部分的侧面，Sketcher → Profile 画如图 3-95，用 constraint  设
定尺寸后，点击 。 

 

图 3-95 
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（6）选择  后，深度设为 Up to last。按鼠标右键，在 Properties 中选择透明度（见

图 3-96）。 
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图 3-96 

26．实例 Part Ⅲ 

（1）用 xy plane → Sketcher → Profile 画如图 3-97。用 constraint  设定尺寸后，

点击 。 

 

图 3-97 

（2）点击  后，长度设为 50mm。选择模型的前面后，用 Sketcher → Profile 画

如图 3-98。用 constraint  设定尺寸后，点击 。 

 

图 3-98 
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（3）选择  后，深度设为 5mm。选择背而后，再点击  键，然后点击 OK 键（见

图 3-99）。 

 

图 3-99 

（4）选择模型的上面后，用 Sketcher → Profile 画如图 3-100。用 constraint  设
定尺寸后，点击 。 

 

图 3-101 

（5）选择  后，深度设为 10mm（见图 3-102）。同样的方法再挖一个小四方形（见

图 3-103）。 
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图 3-102                                图 3-103 

（6）选择被挖出的下面后（图 3-103 虚线部分），用 Sketcher → Profile 画如图 3-104。
用 constraint  设定尺寸后，点击  。 

 

图 3-104 

（7）选择  后，深度设为 Up to last（见图 3-105）。 

 

图 3-105 
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（8）选择底部后，用 Sketcher → Profile 画如图 3-106。用 constraint  设定尺寸

后，点击 。 

 

图 3-106 

（9）点击  后，长度设为 5mm（见图 3-106）。 

 

图 3-107 

27．实例 Part Ⅳ 

（1）用 xy plane → Sketcher → Profile → constraint → Axis 画如图 3-108，点击
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图 3-108 

（2）点击 Shaft，角度设为 360°后，点击 OK 键（见图 3-109）。 

 

图 3-109 
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第 4 章  Wireframe & Surface Design 

1．开始 

在菜单中选择 Start → Mechanical Design → Wireframe and Surface Design（见图

4-1）。 

 

图 4-1 

2．Point 

¤ 生成点的命令，Point 。 
（1）Creating Points by Coordinates  
按坐标生成点，点击  键后，在对话框里各输入 x，y，z 坐标（见图 4-2）。 
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图 4-2 

（2）Creating Points on Curve  
在弧线上生成一个点。用 xy plane → Sketcher – Spline 画一个弧线，然后点击  。

点击  键后，Point type 栏中选 On curve，Curve 栏中用鼠标选窗口中的弧线，length
设为 50mm，点击 OK 键（见图 4-3）。 

 

图 4-3 

* Nearest extremity - 从起点生成点；Middle Point - 从中间位置生成点。 
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（3）Creating Points on plane 
在平面上生成一个点。点击  键后，对话框的 Point type 栏中选择 On Plane，Plane

栏中用鼠标选择 Tree 中的 xy plane，然后输入 H，V 轴的坐标（见图 4-4）。 

 

图 4-4 

（4）Creating Points on Surface 
在曲面上生成点。用 xy plane → Sketcher → spline → Exit → Extrude（ ）生成

一个平面后点击  键。对话框的 Point type 栏中选择 On surface，Surface 栏中用鼠标选

择曲面，长度设为 40mm 后，点击 OK 键（见图 4-5）。 

 

图 4-5 

（5）Creating Circle Center 
在圆或圆弧的中心生成点。用 xy plane → Sketcher → Ellipse 画一个椭圆后点击

。点击  键，Point type 栏中选 Circle/Sphere center，点击 OK 键（见图 4-6）。 

 62



 

 
第4

章  W
irefram

e &
 Surface D

esign
 

图 4-6 

（6）Creating Tangent on Curve 

① 在曲线上面生成点。用 xy plane → Sketcher → spline 画如图 4-7。 

 

图 4-7 

② 再用 yz plane → Sketcher → line 生成一个斜线后点击 （见图 4-8）。 

 

图 4-8 

③ 点击  键，Point type 栏中选 Circle/Sphere center，点击 OK 键。Point type 栏
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中选择 Tangent on curve，Curve 栏中用鼠标选曲线，Direction 栏中用鼠标选直线。如图

4-9 在两条线相切的位置生成点。 

 

图 4-9 

3．Line 

¤ 生成线的命令  
（1）Creating Point-Point 
① 生成连接点之间的线。用 xy plane → Sketcher → spline 生成一个曲线后，点击 

 键生成如图 4-10。 

 

图 4-10 

② 点击  键后，对话框的 Line type 中选择 Point-Point，设起点和终点（见图 4-11）。 
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图 4-11 

（2）Creating Point-Direction 

根据点和方向生成线。Line type 中选择 Point-Point，设起点和终点（见图 4-12）。 

 

图 4-12 

（3）Creating Angle/Normal to Curve 
利用角度生成线的命令。Line type 中选择 Angle/Normal to Curve，设起点和终点（见

图 4-13）。 
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图 4-13 

（4）Creating Tangent to Curve 

生成与曲线相切的命令。Line type 中选择 Angle/Normal to Curve，设起点和终点（见

图 4-14）。 

 

图 4-14 
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（5）Creating Normal to Surface 
生成与 Surface 相垂直的线。Line type 中选择 Normal to Surface，设起点和终点（见

图 4-15）。 
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图 4-15 

4．Circle 

¤ 生成圆的命令，  
（1）Creating Center and Radius 
用中心点和半径生成圆。xy plane → Sketcher → point 生成一个点后点击 ，再

点击 。Circle type 栏中选择 Center and radius（见图 4-16）。 

 

图 4-16 
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（2）Crating Center and Point 
用中心点和一个点生成圆。xy plane → Sketcher → point 生成两个点后点击 ，

再点击 。Circle type 栏中选择 Center and point（见图 4-17）。 

 

图 4-17 

（3）Creating Two point and Radius 
用两个点和半径生成圆。Circle type 栏中选择 Two point and radius，此时生成两个圆，

点击 Next solution 来选择所需的圆（见图 4-18）。 

 

图 4-18 

（4）Three Points 
用三个点生成圆。点击  后，Circle type 栏中选择 Two point and radius，依次选择

三个点（见图 4-19）。 
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图 4-19 

（5）Bitangent and Radius 
用一个点、两个弧线的切点和半径画圆的命令。Element1，Element2 各选两个弧线，

Support 选点（见图 4-20）。 

 

图 4-20 

（6）Bitangent and Point 
用一个点，生成与两个弧线相切的圆。xy plane → Sketcher 生成一个点和两个弧线

后，点击 ，圆的对话框中依次选择。点击 Next solution 选择所需的圆（见图 4-21）。 

 

图 4-21 
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（7）Tritangent 
用三个弧线画圆。图 4-21 中点击  后，依次选择三个弧线，点击 Next solution 选

择所需的圆（见图 4-22）。 

 

图 4-22 

5．Spline 

¤ 生成弧线的命令， 。 
（1）Wireframe and Surface Workbench 中用  键，在 xy plane 中画四个点，然后点

击 。选 Close Spline 时，生成封闭式的弧线，用鼠标右键点击 Tangent Dir 栏时，出现

对话框，可选择 x，y，z 轴，右侧的 Tangent Tension 中选择适当的值（见图 4-23）。 

 

图 4-23 
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6．Creating Corner 

¤ 用一个点和弧线生成倒角的命令， （点击  右下方倒三角形）。用三点画一

个弧线，在倒角对话框中，选择点和弧线，按 Next solution 选择所需的倒角，选择 Trim 
element 2 时，只留下与倒角相切的部分（见图 4-24）。 第4
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图 4-24 

7．Plane 

¤ 生成新作业平面的命令， 。在 Plane type 中选择 Offset from plane，Reference
栏中用鼠标选择适当的平面，然后设定距离（见图 4-25）。 

 

图 4-25 

8．Multisections Surface 

¤ 用不同位置的弧线画一个曲面的命令， 。 图 4-25 中在两个平面中用 Sketcher 
→ Arc 画出两个弧线，点击  后，依次选择（见图 4-26）。 
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图 4-26 

9．Sweep 

¤ 按任意形象生成曲面的命令，  。用 xy plane → Sketcher → Hexagon 画一个

六角形后退出，再用 yz plane → Sketcher → Spline 画一个弧线退出后，点击 。Profile
栏中用鼠标选择六角形，Guide curve 栏中用鼠标选择弧线后点击 OK 键（见图 4-27）。 

 

图 4-27 

10．Revolve 

¤ 用旋转的方法生成曲面的命令， 。 
（1）用 xy plane → Sketcher → Profile 画一个曲线，然后设轴线后退出 Sketcher（见

 72



 

图 4-28）。 

 

第4

章  W
irefram

e &
 Surface D

esign
 

图 4-28 

（2）点击  键，Angle 中可设角度（见图 4-29）。 

 

图 4-29 
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11．Extrude 

¤ 伸出的方式生成曲面的命令， 。用 xy plane → Sketcher → Spline 画一个曲

线后退出， 点击  后，在 Limit 1 的 Dimension 栏中设定宽度。Limit 2 的 Dimension
栏中设定宽度时，反方向位置上又生成曲面（见图 4-30）。 

 

图 4-30 

12．Offset 

¤ 偏移曲面的命令， 。 
（1）用 xy plane → Sketcher → Profile 和 Extrude 命令画如图 4-31，4-32。 

    

图 4-31                            图 4-32 

（2）点击 。Offset 栏中输入要偏移的距离，按 Reverse Direction 键时，可选择方

向（见图 4-33）。 
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图 4-33 

13．Parallel Curve 

¤ 复制平行曲线的命令， （菜单 Start → Shape → Generative Shape Design
中选择）。前面 Extrude 中画出的图形中，点击  键。选择曲线、方向和距离后，点

击 OK 键（见图 4-34）。 

 

图 4-34 

14．Projection 

¤ 曲面中生成投影的命令 ，  。用 xy plane → Sketcher → Spline → Exit → 
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Extrude 画一个曲面，再用 zx plane → Sketcher → Spline → Exit 画一个曲线，然后

点击  键，依次选择曲面和曲线（见图 4-35）。 

 

图 4-35 

15．Intersection 

¤ 用两个元素相交的方法来创建新的元素，根据相交对象的不同，可以创建点或

线，  。在 xy plane，zx plane 中，用 Spline → Extrude 画两个面后，点击 。不好

分辨时，在 Tree 中找到 Intersection（见图 4-36）。 

 

图 4-36 

16．Translate 

¤ 移动曲面的命令，  。 
（1）用 xy plane → Sketcher → Profile → Axis → Exit 后，点击 Revolve  键，
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画如图 4-37，4-38。 

      

第4

章  W
irefram

e &
 Surface D

esign
 

图 4-37                                   图 4-38 

（2）点击  键（见图 4-39）。 

 

图 4-39 

17．Symmetry 

¤ 生成对称曲面的命令，  （点击  右下角的倒三角形）。按照 Translate 步
骤 1 中的画，点击  ，选择图和一条对角线（见图 4-40）。 

 

图 4-40 

18．Thick Surface 

¤ 给无厚度曲面赋予厚度的命令，  。按照 Translate 步骤 1 中的画，此时该曲
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面无厚度， 转到菜单 Start → Mechanical Design → Part Design 或 Start →  Part 
Design 后，点击  键。可以往里或往外生成厚度（见图 4-41）。 

 

图 4-41 

19．Trim 

¤ 删除部分曲面的命令  （点击 Split  键右下角倒三角形）。 
（1）用 xy plane → Sketcher → Rectangle 画如图 4-42 后，点击 。点击 Extrude  

键。 

 

图 4-42 

（2）再用 xy plane → Sketcher → Line 在正方形下面一条线，点击 （见图 4-43，
4-44）。 
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图 4-43                             图 4-44 

（3）点击 Extrude  键，长度设为 180mm（见图 4-45）。 

 

图 4-45 

（4）点击  键。对话框中选择第一次画的四方形上部，再选第二次画的平面，按

OK 键，用 Other side/next element，Other side/previous element 选择所需图形 

 

图 4-46 

20．Rotate 

¤ 旋转图形的命令  （点击 Translate  右下方倒三角形），按照 Translate 步
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骤 1 中的图，点击  键（见图 4-47）。 

 

图 4-47 

21．Affinity 

¤ 按一定的比例和方向变换曲面的命令，  （点击 Translate  右下方倒三角

形），用 Rotate 中的模型，点击  键。Element 栏中用鼠标选择模型，Origin 栏中按

鼠标右键选择所变换的基准点，Rations 中输入 x，y，z 方向上的比例（见图 4-48）。 

 

图 4-48 

22．Join  

¤ 连接成一个模型的命令， 。 
（1）在 xy plane 中生成曲面，再画一条与该平面垂直的线（与 Trim 步骤 1，2 相同），
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Extrude 后变成如图 4-49。 
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图 4-49 

（2）点击  键后，选择两个面，按 Simplify the result，Tree 中可以确认连接（见

图 4-50）。 

 

图 4-50 

23．Split 

¤ 根据基准面删除部分曲面的命令  。用 Translate 步骤 1 的图，点击  键。 
Element to cut 栏中用鼠标选择模型，Cutting elements 栏中按鼠标的右键后，选择所需

基准面后，点击 OK 键（见图 4-51）。 

 81



 
CATIA V5 实用教程 

 

图 4-51 

24．Scaling 

¤ 根据基准面缩放曲面的命令 （点击 Translate  右下方倒三角形），在前面

的模型中点击  键。Element 栏中选择模型，Reference 栏中按鼠标的右键后选择缩

放的方向，Ratio 栏中输入比例（见图 4-52）。 

 

图 4-52 

25．Close Surface 

¤ 封闭曲面的命令 。 
（1）用 xy plane → Sketcher → Spline 画如图 4-53 后，生成曲面如图 4-54。 
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图 4-53                                    图 4-54 

（2）菜单中 Start → Mechanical Design → Part Design 中选择 Close Surface  。
Object to Close 栏中用鼠标选择模型（见图 4-55）。 

 

图 4-55 
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第 5 章  Assembly 

1．开始 

¤ 选择菜单中 Start → Mechanical Design → Assembly Design（见图 5-1）。 

 

图 5-1 

2．Existing Component 

¤ 引入要装配的文档  。点击  后，再按窗口左侧 Tree 中最上面的 Product 1， 
选择要装配的所有零件图（按 Ctrl 键后选择），点击 OK 键（见图 5-2，5-3）。出现 Part 
number conflicts 对话框时，点击 Rename 键，重新给零件起名（可用数字或英文）。 
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图 5-2                                       图 5-3 

* 可重复使用 Existing Component 功能（Part 4 要打开两次）. 

3．Manipulation 

¤ 调整位置的命令  。点击该键时，出现如下对话框（见图 5-4），调整各零件

的位置，如图 5-5。 

 

图 5-4 

- 选择  键后，用鼠标的左键拖动模型时，按 X 轴方向移动； 
- 选择  键后，用鼠标的左键拖动模型时，按 XY 平面方向移动； 
- 选择  键后，用鼠标的左键拖动模型时，按 X 轴方向旋转。 
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图 5-5 

按窗口右侧工具栏中的 Explode  时，自动分离各零件。 

4．Fix Component 

¤ 固定对某些零件位置，作为其他零件约束条件设置时的参考，点击  键后选

择一个模型，模型中出现被固定的图标（见图 5-6）。 

 

图 5-6 

5．Offset Constraint 

¤ 确定装配位置的命令，  
（1）装配 Part 2 和 Part 3。点击  键后，选择 Part 3 的一个边角和相对应的 Part 2
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的一个边，Offset 栏中距离设为 0mm，点击 OK 键（见图 5-7）。 
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（2）点击窗口下方的  键（菜单中 Analyze → Update）后，两个零件的一个边

的位置调整到一起（见图 5-8）。 

 

图 5-8 

6．Contact Constraint 

¤ 装配时，定义接触面的命令  。 
（1）选择 Part 2 和 Part 3 要接触的面后，点击  键（见图 5-9，5-10）。 
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图 5-9                                  图 5-10 

（2）按同样的方法装配 Part 1 如图 5-11（点击  选择相互接触的对应点，距离设

为 0mm，点击 ） 

 

图 5-11 

7．Coincidence Constraint 

¤ 在同一个轴上约束零件的命令 。 
（1）装配部件和 Part 4。选用  功能，在适当的位置上调整好 Part 4（见图 5-12）。 

 

图 5-12 
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（2）点击  键后，选择相互对应圆柱部分的轴线（鼠标放到圆柱位置时，自动出

现轴线），点击 （见图 5-13）。 
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图 5-13 

（3）用  功能选择相对应的面，距离设为 0mm（见图 5-14）。 

 

图 5-14 

（4）点击  键，最终装配结果如图 5-15。 

 

图 5-15 
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第 6 章  Generative Structural Analysis 

1．开始 

¤ 选择菜单中 Start → Analysis & Simulation → Generative Structural Analysis
（见图 6-1）。 

 

图 6-1 

2．User Material 

¤ 生成材质的命令 Material on Analysis Connection 。 
（1）在 Part Design 中用 Profile → Circle → Pad 画如图 6-2 后，进入 Generative 

Structural Analysis（选择菜单 View → Render Style → Customize View，对话框中选择



 

Shading、Outline 和 Materials）。 
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图 6-2 

（2）点击窗口下面的  键，在 Library → Metal 中选择 Aluminium。双击 Material
时，出现 Properties 对话框，可以修改 Poisson Ratio，Density，Thermal Expansion，Yield 
Strength 值。 

3．Clamp 

¤ 生成一个夹持约束的命令  。 使夹持对象的 6 个自由度均被固定。在进行有

限元分析之前，要把对象的全局自由度全部约束住，否则在计算中会出现歧异性（见图

6-3）。 

 

图 6-3 

4．Distributed Force 

¤ 加分布力的命令  。点击该键后，选择一个面。 对话框中 Z 轴的力量设为

-100N（见图 6-4）。 
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图 6-4 

5．Compute 

¤ 对几何体进行网格划分和计算的命令  。对前面的处理（Clamp，Distributed 
Force）结果进行计算（见图 6-5）。 

 

图 6-5 

6．Von Mises Stress 

¤ 显示应力图像的命令   
（1）计算结束后，显示应力图像。移动鼠标时，现示该位置的应力（见图 6-6）。 
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图 6-6 

（2）选择窗口下面的 Amplification Magnitude  键，用 Factor 值调整变形，如图

6-7（选择菜单 View → Render Style → Customize View，对话框中恢复初始设置）。 

 

图 6-7 

7．Surface Mesh 

¤ 显示网络的命令 。选择菜单 Start → Analysis & Simulation → Advanced 
Meshing Tools。点击  后，在对话框中调整 Mesh Size，其效果如图 6-8。 

 

图 6-8 
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8．Displacement 

¤ 显示位移的命令  。用鼠标点适当的位置（见图 6-9）。 

 

图 6-9 

9．Precision 

¤ 显示精度的命令  （点击  右下角倒三角形），其效果如图 6-10。 

 

图 6-10 

10．Principal Stress 

¤ 显示主应力的命令  （点击  右下角倒三角形），其效果如图 6-11。 

 

图 6-11 
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11．Enforced Displacement 

¤ 生成强制位移的命令  （见图 6-12）。 
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图 6-12 

12．Pressure 

¤ 加外部负荷的命令  。与 Traction 功能相似，可调整力度（见图 6-13）。 

 

图 6-13 

13．Moment 

¤ 加外部力矩的命令 （如图 6-14）。 
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图 6-14 

14．Acceleration 

¤ 加过载的命令  （如图 6-15）。 

 

图 6-15 
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15．Rotation Force 

¤ 加旋转力的命令 （见图 6-16）。 

 

第6

章  G
enerative Structural A

nalysis  

图 6-16 

16．Animate 

¤ 显示动画的命令 （在窗口下面的工具条中），如图 6-17。 

 

图 6-17 
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第 7 章  Drafting 

1．开始 

¤ 三维图形转换成二维图形 
（1）选择菜单中 Start → Mechanical Design → Drafting（见图 7-1）。 

 

图 7-1 

（2）打开后，出现如下对话框（见图 7-2）。可设定图纸的大小，然后选择适当的图

纸布置方式。 
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图 7-2 

（3）点击 OK 键后，变成二维图纸模式（见图 7-3）。 

 

图 7-3 

（4）窗口左上方 Tree 的 Sheet.1 中，按鼠标右键，在 Properties 中可设定比例等其他

属性（见图 7-4）。 

    

图 7-4 
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2．View 

¤ 按用户指定的方式生成视图 
（1）Front View ，（生成正面视图） 
① 打开一个模型（在此打开了 Part 3）后，选择 Start → Mechanical Design → 

Drafting → 正面视图。菜单中选择 Windows → Tile Horizontally； 
② 按 front view 后，模型中选择一个面，生成该面的正面视图； 
③ 正面视图周围出现绿色虚线框时，可以调整位置； 
④ 按右侧方位箭头时，视图发生旋转（见图 7-5）。 

 

图 7-5 

（2）Projection View （点击  右下方倒三角形），自动生成侧视图（见图 7-6）。 

 

图 7-6 
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（3）Auxiliary View （点击  右下方倒三角形），按所需方向，生成补助视图

（见图 7-7）。 
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图 7-7 

（4）Isometric View  （点击  右下方倒三角形），生成与三维视图相同的二维

视图（见图 7-8）。 

 

图 7-8 
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3．Detail View 

¤ 生成详细视图的命令， 。 
（1）返回到步骤 7.2.3 后，点击 Detail View  ，在视图中选择适当位置（见图 7-9）。 

 

图 7-9 

（2）Detail View Profile  （点击  右下方倒三角形），用 Profile 选择详细查看

部位（见图 7-10）。 

 

图 7-10 

4．Clipping View 

¤ Clipping View  和 Clipping View Profile  ，与 Detail View 功能相似。 

5．Dimension 

¤ 定义尺寸的命令 Creating Dimension 。 
（1）点击  键后，选择右侧一条线，出现 60 的尺寸，再按尺寸键后，选上面一

条线和下面一条线，出现 90 的尺寸标注（见图 7-11）； 
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图 7-11 

（2）Dimension Text，上图中鼠标放到尺寸线后，按右键选择 Properties，选择 Prefix
栏右键时，可以选择标注，Associated Texts 栏中输入文字，在相应位置上（上下左右）

显示（见图 7-12）； 

 

图 7-12 

（3）Value ：Value → format 中（按下面 More）设定单位等属性； 
（4）Tolerance：Tolerance 栏中输入公差属性； 
（5）Dimension Line：设定尺寸标注属性； 
（6）Extension Line：设定尺寸辅助线属性。 
* 用鼠标按尺寸线或尺寸后拖动，可以调整位置； 
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* 选择菜单中 Insert → Generation → Generate Dimensions 时，显示所有的尺寸，

选择 Generate Dimensions Step by step 时，按步骤自动生成尺寸。 

6．Datum 

¤ 图纸上设定基准的命令 
（1）Datum target （点击  右下方倒三角形），双击后可以修改基准面（见图

7-13）； 

 

图 7-13 

（2）Geometrical Tolerance  ，输入几何公差（见图 7-14）。 

 

图 7-14 

7．Text 

¤ 输入文字的命令 。 
（1）Text：图纸选择适当的位置，选择 Text 键后输入文字（见图 7-15）； 
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图 7-15 

（2）Text with Leader，输入文字后，可变换箭头位置（见图 7-16）。 第7
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图 7-16 

（3）Ballon，生成气球箭头（见图 7-17）。 

 

图 7-17 

8．Roughness Symbol 

¤ 输入表面粗糙度的命令， （见图 7-18）。 

 

图 7-18 
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（1）Ra：表面粗糙度； 
（2）粗糙度值； 
（3）记录研磨余量（ISO 规定）； 
（4）需要研磨工程时记录加工方法（L，D，B，M 等）； 
（5）Rmax 或 Rz 表面粗糙度值； 
（6）输入对各表面粗糙度值研磨量和测定值。 

表面粗糙度的算法 
（1）中心线计算法：国际标准； 
（2）最高值计算法：Rz； 
（3）十点平均算法：Rmax 或 Rs。 

表面粗糙度表示方法 
（1） ：指示输入表面粗糙度值的面； 
（2） ：切削加工指示面； 
（3） ：保留指示面[与（2）正相反]。 

9．Welding Symbol 

¤ 输入焊接符号的命令  ，把 2.0mm 深槽周围全部焊接（见图 7-19）。 

 

图 7-19 
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第 8 章  Generative SheetMetal Design 

1．开始 

¤  设计薄板的功能。选择菜单中 Start →  Mechanical Design →  Generative 
SheetMetal Design（见图 8-1）。 

 

图 8-1 

2．Sheet Metal Parameters 

¤ 设定薄板参数， 。 
（1）设 Thickness（1mm），Bend Radius（8mm）； 
（2） Bend Extremities 中选择 Tangent，点击 OK 键后，在 Specification Tree 中生成
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PartBody 和 Sheet Metal Parameter.1（见图 8-2）。 

 

图 8-2 

3．Wall 

¤ 生成壁的命令， 。用 xy plane → Sketcher → Rectangle 生成一个四方形后，

点击  键。Selection 栏中用鼠标右键选择四方形（见图 8-3）。 

 

图 8-3 

4．Wall on Edge 

¤ 生成侧壁的命令， 。点击  后选择一个边，Value 中输入高度，点击 OK
键（见图 8-4）。 
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图 8-4 

* Wall Definition Box 
（1）Length：壁的高度； 
（2）Angle：壁的角度； 
（3）Invert Material Side：调整壁厚度的生成方向； 
（4）Invert Sketch Profile：调整壁的生成方向。 

5．Cut Out 

¤ 删除壁的命令  。图 8-4 中，点侧面后进入 Sketcher 后画两个圆，退出后点

击 。Type 栏中选择 Up to last，点击 OK 键（见图 8-5）。 

 

图 8-5 
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6．Bends 

¤ 薄板折叠处生成倒角的命令， 。Support 1 和 2 各选两个薄板，属性中半径已

设为 8mm（见图 8-6）。 

 

图 8-6 

7．Fold / Unfold 

¤ 展开被折边薄板的命令  。图 8-6 中点击  键时，展开被折边的部分，再

点击时恢复到原状（见图 8-7）。 

 

图 8-7 

8．Extracting Drawings From the Sheet Metal Part 

¤ 变换 Drawing 的命令 
（1）点击窗口下方的  后，选择 Drawing，在出现的对话框中设定属性（见图 8-8）。 
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图 8-8 

（2）在菜单中选择 Windows → Tile Vertically，选择 Unfolded View 后点击 （鼠

标各控制两个窗口），其效果如图 8-9。 

 

图 8-9 

9．Flange 

¤ 设定角度后折边的命令，  。Spline 栏中选择一个边，设定长度后点击 OK 键

（见图 8-10）。 

 

图 8-10 
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10．Hem 

¤ 180°折边的命令，  （点击  右下方倒三角形），如图 8-11。 

 

图 8-11 

11．Tear Drop 

¤ 折边后与平面相接触  （点击  右下方倒三角形），如图 8-12。 

 

图 8-12 

12．Surface Stamping 

¤ 生成打印痕的命令 （如下功能点击右下方倒三角形）。 
（1）Circular Stamp  
① 用 xy Plane → Sketcher  → Profile 生成如图 8-13 后退出 Sketcher， 点击  ，

壁的生成方向朝下（见图 8-14）； 
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图 8-13                                图 8-14 

② 点击  键，设定属性（见图 8-15）。 

 

图 8-15 

（2）Flange Hole，  。点击 时，生成冲压痕（见图 8-16）。 

 

图 8-16 
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（3）Surface Stamp， 。 
① 选择一个面后，用 Sketcher → Elongated Hole 生成如图 8-17 后退出 Sketcher； 

 

图 8-17 

② 点击  ，设定属性（见图 8-18）。 

 

图 8-18 

13．Stiffening Rib 
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¤ 生成加强肋的命令 ，选择 Bend 后，点击  键，设定属性（见图 8-19）。 

 

第8

章  G
enerative SheetM

etal D
esign  

图 8-19 

14．Rectangular Pattern 

¤ 按矩形模式的方法生成图形 ，如图 8-20（操作方法与 Part Design 的 Pattern
相同）。 
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图 8-20 

15．Walls Recognition 

¤ 识别壁的命令  。在其他环境中（比如 Part Design）生成的薄片部件转换成

钣金件对象。在 Part Design → xy Plane → Pad →  画如下图后，点击 ，

Reference face 栏中用鼠标选择四方形，faces to be recognized as walls 栏中依次选择各

个面（见图 8-21）。 

 

图 8-21 

16．Designing 

¤ 生成 Sheet Metal Part 的命令  
（1）打开 Assembly design 后，按 Components → New Part，重复三次后 Tree 变成

如图 8-22； 
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图 8-22 

（2）双击 Part1中的 PartBody后进入 Part Design界面，选择 xy plane后，点击 Sketcher 
 键。用 Profile  和 Axis  画如图 8-23，点击  +  + （厚度设为 20mm），

效果如图 8-24； 第8
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图 8-23                                       图 8-24 

（3）双击 Part2 中的 PartBody 后进入 Part Design 界面，选择 xy plane 后，点击

Sketcher  键， 用 Arc 和 Axis  画如图 8-25，按  + ，效果如图 8-26； 

     

图 8-25                                    图 8-26 

（4）点击  ，选择半球后，点击 OK 键； 
（5）菜单中选择 Generative Sheetmetal Design，用 Part3 的 yz plane → Sketcher → 

Profile 画如图 8-27 后，点击 ； 
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图 8-27 

（6）点击  后，设 Thickness=1mm，Default Bend Radius=8mm，点击  ，First 
Limit → Length 1 设为 5mm，Second Limit → Length 2 设为 5mm（见图 8-28）； 

 

图 8-28 

（7）在 Properties 中变换颜色后最终模型如图 8-29，左侧显示所有的 Specification 
Tree。 
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图 8-29 
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第 9 章  Generative Shape Design 

1．开始 

¤ 选择菜单中 Start → Shape → Generative Shape Design（见图 9-1）。 

 

图 9-1 

* Generative Shape Design 中好多功能和 Wireframe and Surface Design 重复。 

2．Fill 

¤ 在选择的领域中生成Surface的命令 。重复三次xy plane → Sketcher → Line 
→ Exit，再用 xy plane → Sketcher → Spline → Exit 画如下图后，点击 选择曲线

与中间的直线后，点击 OK 键（见图 9-2，9-3）。 



 
CATIA V5 实用教程 

      

图 9-2                                         图 9-3 

3．Split 

¤ 删除选择领域的命令 。 

（1）用 xy plane → Sketcher → Profile → Exit 画如下图后，点击 ；再进入 xy plane
画一个圆后退出，点击 （见图 9-4，9-5）； 

     

图 9-4                                         图 9-5 

（2）Element to cut 栏中用鼠标选平面，Cutting Elements 栏中鼠标选圆，点击 OK 键

（见图 9-6）； 

 

图 9-6 

 120



 

（3）进入 xy plane，用 spline 画曲线后退出，点击  。Element to cut 栏中用鼠标

选平面，Cutting Elements 栏中鼠标选曲线，选择 Other side 时删除面发生变化（见图 9-7）。 
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图 9-7 

4．Boundary 

¤ 显示领域的命令 。图 9-7 中按该键时，显示领域（见图 9-8）。 

 

图 9-8 

5．Connect Curve 

¤ 连续线上的两点之间画弧线的命令 。 

（1）用 xy plane → Sketcher → Point 画如图 9-9 后，退出 Sketcher，用 Line 连接四

个点（见图 9-10）； 

 121



 
CATIA V5 实用教程 

     

图 9-9                          图 9-10 

（2）点击  键，对话框 First Curve 的 Curve 栏中用鼠标选上面的线，Point 栏中用

鼠标选上线右侧点（按鼠标的右键可设定点的位置），Second Curve 的 Curve 栏中用鼠标

选下面的线，Point 栏中用鼠标选下线左侧点（按鼠标的右键可设定点的位置），如图 9-11。 

 

图 9-11 

6．Shape Fillet 

¤ 生成不同形状的图形之间生成圆角的命令   

（1）用 xy plane → Sketcher → Line → Exit → Extrude 画如图 9-12。 
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图 9-12 

（2）选择面后，再点击 ketcher，在中间位置上再画一条线后，Exit → Extrude（见

图 9-13，9-14）； 

            

图 9-13                              图 9-14 

（3）点击 ，Trim support 1 栏中用鼠标选一个面，trim support 2 栏中用鼠标选另一

个面，Radius 设为 30mm，点击 OK 键（见图 9-15）。 

 

图 9-15 
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7．Extrapolate 

¤ 延长曲线或 Surface 的命令 。 
（1） 用 xy plane → Sketcher → Arc，Spline → Exit 或 Shape Design 3D 状态下用

point Spline 画如图 9-16； 

 

图 9-16 

（2）点击  ，Boundary 栏中用鼠标选曲线的一端，Extrapolated 栏中用鼠标选曲

线， length 设为 120mm（见图 9-17）； 

 

图 9-17 

（3）用 xy plane → Sketcher → Arc → Exit → Extrude 画曲面如图 9-18，点击 ，

Boundary 栏中用鼠标选曲面底线，Extrapolated 栏中用鼠标选曲面，length 设为 60mm，

其结果见图 9-19。 
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图 9-18                               图 9-19 
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第 10 章  Free Style 

1．开始 

¤ 选择菜单中 Start → Shape → Freestyle（见图 10-1）。 

 

图 10-1 

2．Planar Patch 

¤ 用两个点生成平面的命令  ，点击该键后，在窗口中点适当的位置后拖鼠标

（见图 10-2）。 
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图 10-2 

3．Control Point  

¤ 调整生成平面的命令 ，对话框中 Support 是定义变换方向，Diffusion 和 
CrossDiff 是定义变换形式，选择所需变换键（用图 10-2）。 

（1）Control Point Using Translation in the Plane 
① 对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Diffusion → 

Concave Law）（见图 10-3）； 

 

图 10-3 

② 用鼠标双击 Nv 和 Nu 时，增加线数。 
（2）Control Point Using Translation Along the Direction 
对话框中点击 键，用鼠标按住平面上的某一点后往上拉（选择 Diffusion → 

Concave Law）（见图 10-4）。 
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图 10-4 

（3）Control Point Using Translation Along Mesh Line 
对话框中点击 键，用鼠标按住右侧中间点后往右拉（对话框的 Advanced → 

Harmonization 中选择 Mean Plane）（见图 10-5）。 

 

图 10-5 

（4）Control Point Using Translation Along Local Tangent 
对话框中点击 键，用鼠标按住右侧中间点后往右拉（选择 Diffusion → Concave 

Law）（见图 10-6）。 

 

图 10-6 
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（5）Control Point Using Translation Along the Normals 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Diffusion → Concave 

Law）（如图 10-7）。 
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图 10-7 

（6）Control Point Using Move Selected Points Identically 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Support → Normal to 

compass）（见图 10-8）。 

 

图 10-8 

（7）Control Point Using Stretch Selected Points 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Support → Normal to 

compass）（见图 10-9）。 

 

图 10-9 
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（8）Control Point Using Stretch Selected Points Using a Concave Law 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Support → Normal to 

compass）（见图 10-10）。 

 

图 10-10 

（9）Control Point Using Stretch Selected Points Using a Convex Law 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Support → Normal to 

compass）（见图 10-11）。 

 

图 10-11 

（10）Control Point Using Stretch Selected Points Using a Bell Law 
对话框中点击 键，用鼠标按住右侧中间点后往上拉（选择 Support → Normal to 

compass）（见图 10-12）。 
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4．4 – Point Patch 

¤ 用四个点生成面（点击 右下方倒三角形）。 
（1）用 Planar Patch  和 Control Point 生成如图 10-13 后，点击 。在曲面上

依次选四个点后生成一个面（在 Properties 中变换颜色）（见图 10-14）； 

  

图 10-13                                  图 10-14 

（2）用鼠标选窗口右上方的坐标的中心点后，拉到新生成的面上出现一个对话框，

点击 OK 键（见图 10-15）； 

 

图 10-15 
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（3）移动坐标时，新生成的面也随坐标移动（双击坐标面时，可设定属性）（见图

10-16）。 

 

图 10-16 

5．3 – Point Patch 

¤ 用三个点生成平面的命令 （点击 右下方倒三角形），选择该键后，依次选

择三个点（见图 10-17）。 

 

图 10-17 

6．FreeStyle Blend Surface 

¤ 用四个点生成平面的命令 。先画好两侧的面，点击 时，两个面之间用四个

点自动形成搭接面（见图 10-18）。 
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图 10-18 

7．Global Deformation 

¤ 把所有的面设定为一体的命令 。图 10-18 中选择三个面（Ctrl 键）后，点击 ，

选择 No Guide 后按 Run 键，出现 Control Points 对话框，变换时三个面同时发生变化

（见图 10-19）。 

 

图 10-19 
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8．Curve on Surface 

¤ 平面上生成自由曲线的命令， 。Options 中 Creation Type 和 Mode 中选择各

种形式的曲线（见图 10-20）。 

 

图 10-20 

9．Isoparametric Curve 

¤ 在曲面上生成轮廓线的命令 。点击 后曲面上选择适当的位置（见图 10-21）。 

 

图 10-21 

10．FreeStyle Blend Curve 

¤ 连接二个曲线的命令 。用 画两个曲线后，点击 ，依次选择（见图 10-22）。 
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图 10-22 

11．FreeForm Extend 

¤ 延伸曲线的命令 。点击该键后，选择一个曲线，双击数字后调整长度（见图

10-23）。 

 

图 10-23 

12．Fill 

¤ 充填曲面的命令 （点击 右下方倒三角形）。画如图 10-24 后，按 ，用 Ctrl
键，依次选择四个面的边（见图 10-25）。 
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图 10-24                              图 10-25 

13．Freeform Offset 

¤ 复制曲面的命令 ，上图中点击该键后，选择一个面，双击数字后调整距离（见

图 10-26）。 

 

图 10-26 
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第 11 章  DMU Navigator 

Digital Mock Up 

DMU 是实用的对整个产品或产品的部分进行计算机电子模拟的技术。它需要具有完

整的功能，包括集成的造型、可视化、功能性检测、产品结构和配置管理等功能，为数

据管理、信息传递和决策过程三大领域提供方案。最终能更快、更好地以最低成本开发

和生产汽车和其他产品。 

DMU Kinematics 

对整体的设计图进行检测，并实现机构传动，用 Evolution Curve 显示和实现复杂连

接件的运动轨迹。 

DMU Navigator 

电子样机浏览器等功能都是为支持电子样机 DMU 而开发的先进技术，提供 Walk、
Fly 功能；可对三维 Mockup 中的 Hyperlink，Annotation，Mark 进行协同工作，还利用

DMU Kinematics，DMU Fitting Simulator 功能扩大检测能力。在虚拟产品开法管理环境

下的电子样机 DMU 技术是当今最完善的数字化产品开发环境。 

DMU Fitting 

实现装配和维护过程中的装、拆的三维模拟，还能通过零件之间的干涉与最小距离

来分析零件的运动轨迹。 

DMU Space Analysis 

使用于干涉检查、剖面分析与测量和三维几何比较工具进行电子样机验证。该模块

可以进行碰撞、间隙和接触计算，并且可以让用户查看干涉的具体信息，还可以进行三

维几何图形比较并用一个专门的窗口显示比较结果。用户可以对计算结果进行剖视，并

在剖面上进行测量以便更进一步地了解并评估被比较对象之间的差异。电子样机空间分

析通过确保对问题的很好的理解来实现设计校验功能，从而很快地解决问题。该模块可

以用来处理数字化样机的检查问题，用于产品封装打包过程，以及用于从关联设计到维

修检查的全产品生命周期之中，可以处理从日用消费品到汽车、航空航天、厂房布置、

造船或其他重型机械产品等各种规模的电子样机。 
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1．开始 

¤ 选择菜单中 Start → Digital Mockup → DMU Navigator（见图 11-1）。 

 

图 11-1 

2．Inserting Components 

¤ 打开已生成文档的命令  。 
（1）菜单中选择 Insert → Existing Component 后，用鼠标点击窗口左上角 Tree 的

Product1，出现 File Selection 对话框，选择文档； 
（2）Navigating in Examine Mode，Managing View 的操作方法与 Part Design 中的操

作法相同。 

 

图 11-2 
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* 出现 Part number conflicts 对话框时，按 Rename 键，重新定义文件名。 

3．Navigating in Beginner’s Fly Mode 

¤ 按飞行模式显示的命令  
（1）选择窗口下方的 View Toolbar 中的 Fly  键，再点击 Turn Head  ，用鼠

标在图 11-3 选择适当的点； 
第11

章  D
M

U
 N

avigator  

 

图 11-3 

（2）用鼠标左键点击窗口或模型时，模型发生移动，点击 Examine Mode  时，

退出飞行模式； 
（3）选择菜单 View → Navigtion Mode → Walk 后，窗口下方出现 Walk  键。点

击该键后鼠标点击窗口时，按走路的模式显示模型。 

4．Look at Objects 

¤ 改变视线方向或距离的命令 。 
（1）点击  后，用鼠标点模型的任意位置时，该位置移动到窗口中央； 
（2）点击  ，用鼠标选择模型的适当位置后，按住左键后拖拉时，出现四方格，

调整放大部位与视线方向，被选的部分放大并移动到窗口中央（见图 11-4）。 
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图 11-4 

5．Managing URL 

¤ 生成连接网页或其他操作的命令，选择 Hyperlink  后，用鼠标点击模型时，

出现对话框，输入文件名，Browse 中选择路径，选择后点击 Go to 键（见图 11-5）。 

 

图 11-5 

6．Magnifier 

¤ 用新的小窗口放大某一部位的命令  。点击  +  键后用鼠标选择模型的

某一部位，模型以该部位为中心移动，并显示小窗口放大该部位（见图 11-6）。 

 

图 11-6 
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7．Depth Effects 

¤ 设定深度和雾状来显示模型的命令  。对话框中调整圆两侧线的位置来控制

深度，选择 Foggy 时，产生雾状（见图 11-7）。 
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图 11-7 

8．Horizontal Ground 

¤ 水平方向上生成平面的命令  ，点击该键后出现一个平面，用鼠标的按住后

调整位置（见图 11-8）。 

 

图 11-8 
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9．Lighting 

¤ 控制光源的种类、照度、散发量、反射量等属性的命令 （见图 11-9）。 

 

图 11-9 

10．Enhanced Scene 

¤ 不改变当前 View 和 Product 属性情况下，用户自行变更 View 和 Product 属性

后保存 View，演示或比较形象时，可以调出已储存 View 的命令 。 
（1）点击  键。Definition 选择 Automatic naming，Overload Mode 选择 Partial 后，

点击 OK 键（见图 11-10）； 

 

图 11-10 
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（2）窗口变颜色并出现 Enhanced Scene 对话框； 
- Explode  ：分解装配的 Product； 
- Save ViewPoint  ：把当前的 ViewPoint 保存为 Scene View； 
- Overload Positions/Hide-Show/Graphic/Node Activation  ：保存各自的特性； 
- Apply Scene on Assembly  ：Scene 中变更的特性（Position, Hide-Show, Graphic, 

Node Activation） 应用到 Assembly 中； 
- Apply Assembly on Scene  ：Assembly 中变更的特性应用到 Scene 中； 第11

章  D
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- Exit Scene  ：退出 Scene。 
（3）点击  后，再点击 Apply Scene on Assembly  键，选择应用到 Assembly

特性（见图 11-11）； 

 

图 11-11 

（4）点击 Apply Assembly on Scene  ，选择剩余的属性后，点击 OK 键（见图 11-12）。 

 

图 11-12 
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11．Defining Groups of Products 

¤ 定义组的命令  。点击该键后出现 Edit Group 对话框和 Preview 对话框，选

择零件时，在 Preview 中显示（见图 11-13）。 

 

图 11-13 

* 窗口左侧的 Tree 中也可以选择零售。 

12．Viewpoint Palette 

¤ 在作业窗口中准确地变换 Viewpoint 的命令。菜单中选择 View → Viewpoint 
Palette 。选择窗口下面的 Previous 和 Next（ ）键时，可以显示前后示图（见图 11-14）。 

 

图 11-14 
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13．Geometry Overview 

¤ 缩放特定部位的命令。菜单中选择 View → Geometry Overview，缩小对话框

中模型时，主窗口的模型变大（见图 11-15）。 
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图 11-15 
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第 12 章  DMU Fitting Simulator 

1．开始 

¤ 选择菜单中 Start → Digital Mockup → DMU Fitting（见图 12-1）。 

 

图 12-1 

2．Defining the Moving Model 

¤ 定义 Shuttle 变换的命令  。 
（1）打开文档后，点击  键（见图 12-2）； 
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图 12-2 

（2）选择盖时，出现 Manipulator、Edit Shuttle 对话框和 Preview 窗口，点击 OK 键

（见图 12-3）。 

 

图 12-3 

3．Recording the Motion of Moving Models 

¤ 定义 Shuttle 后，保存 Shuttle 变换的命令  。选择菜单中 Insert → Simulation，
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出现 Edit Simulation 对话框，每变换一个位置后，按 Insert 后保存（见图 12-4）。 

 

图 12-4 

4．Simulation Player 

¤ 确认已保存结果的命令  。点击该键后，出现 Player 对话框，用鼠标选择窗

口左侧 Tree 中 gh 的 Simulation，选择 Parameters（Ctrl+Shift+P）  时，可以设定

Sampling 和 Temporization（见图 12-5）。 

 

图 12-5 

 

 148



 

第 13 章  DMU Kinematics 

1．开始 

¤ 选择菜单中 Start → Digital Mockup → DMU Kinematics（见图 13-1）。 

 

图 13-1 

2．Revolute Joints 

¤ 利用轴与面连接的命令 。 
（1）菜单中选择 Insert → Existing Component 后，重复四次打开 Part 中生成的模型，

菜单中选择 Start → Assembly Design，点击 Manipulation  后如图排列（见图 13-2，
13-3）； 
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图 13-2                                    图 13-3 

（2）回到 DMU Kinematics Workbench 后，点击  键，对话框中点击 New 
Mechanism（见图 13-4）； 

 

图 13-4 

（3）鼠标放到 Line 1 后，点击形成半圆的轴线，下图中再找 Line 2（见图 13-5）； 

 

图 13-5 

（4）鼠标放到 Plane 1 后，点击图中上面，下图中选模型的底面为 Plane 2，点击 OK
键（见图 13-6）； 
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图 13-6 

（5）同样的方法连接成图 13-7（左上部的轴没连接在一起）。 

 

图 13-7 

3．Creating Cylindrical Joints 

¤ 连接圆筒形模型的命令  （点击  右下方倒三角形）。上图中点击  键后

出现 Cylindrical Joints 对话框，选择没连接的两个轴线，点击 OK 键（见图 13-8，13-9）。 

        

图 13-8                              图 13-9 
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4．Defining a Fixed Part 

¤ 固定作为基准模型的命令  。点击该键后上图中任意选一个零件（见图

13-10）。 

 

图 13-10 

5．Simulating with Commands 

¤ 确认连接件 Mechanism 的命令 。 窗口左侧的 Tree 中双击 Revolute.1 后，

对话框中选择 Angle driven。点击  键后出现 Kinematics Simulation 对话框，用

Command bar 来确认机构移动（见图 13-11）。 

 

图 13-11 

6．Running a Kinematics Simulation With Command 

¤ 确认独立模型 Mechanism 的命令。窗口左侧的 Tree 中删除 Cylindrical Joints，
双击 Revolute.1、Revolute.2 和 Revolute.3 后，对话框中选择 Angle driven。点击  键
后出现 Kinematic Simulation 对话框，用 Command bar 来确认各机构移动，按 More
后，可以演示（见图 13-12）。 
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图 13-12 

7．Assembly Constrains Conversion 

（1）菜单中选择 Insert → Existing Component 后，重复两次打开 Part 中生成的螺母

和螺栓；菜单中选择 Start → Assembly Design，用  、  和  键（如图 13-13）
装配；固定螺母 ； 

 

图 13-13 

（2）点击 Assembly Constraints Conversion  键，点击 New Mechanism，选择

Mechanism.1 后，点击 More 键（见图 13-14）。 

 

图 13-14 
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（3） 选择 Coincidence 后，Add command 中选择 Angle & Length，再点击 Create Joint
和 Create Fixed Part（见图 13-15）； 

 

图 13-15 

（4）点击 OK 键，用鼠标双击 Tree 中生成的 Cylindrical Joint，点击 OK 键（见图

13-16）； 

 

图 13-16 
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（5）选择 Simulation With commands  ，调整 Command.1 和 Command.2（见图

13-17）； 
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图 13-17 

（6）点击 Play forward  ，螺母一边旋转一边移动（见图 13-18）。 

 

图 13-18 
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第 14 章  DMU Optimizer 

1．开始 

¤ 选择菜单中 Start → Digital Mockup → DMU Optimizer（见图 14-1）。 

 

图 14-1 

2．Generating a Silhouette 

¤ 生成产品外形轮廓的命令 。 

（1）选择菜单 File → Open  打开文档（见图 14-2）； 

 

图 14-2 



 

（2）点击 Silhouette  键。对话框的 Definition → Selection 栏用鼠标选择窗口左

侧 Tree 中的 Product1，Accuracy 设为 2mm（见图 14-3）； 
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（3）点击 Accuracy Wiew(s)栏右侧 Select the wiew（s）键时，出现对话框，选择 Front
后，按 Preview 键，出现 Preview 小窗口（见图 14-4）； 

 

图 14-4 

（4）点击 Save 键保存，此时文件的扩展名为.cgr。 

3．Creating a Wrapping 

¤ 显示包装效果的命令 。对话框的 Definition → Selection 栏用鼠标选择窗口左
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侧 Tree 中的 Product1，Grain 值越小，包装厚度越薄。按 Save 键保存，此时文件的扩

展名为.cgr（见图 14-5）。 

 

图 14-5 

4．Generating an Offset 

¤ Surface 中生成加厚的命令  。菜单中选择 Insert → Existing component，打

开文档（在 Sheet Metal Design Workbench 中设计的模型），点击  后，Selection 栏

用鼠标选择窗口左侧 Tree 中的 Product1（或直接选模型），Offset 设为 12mm，点击 Save
键保存，此时文件的扩展名为.cgr（见图 14-6）。 

 

图 14-6 
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第 15 章  DMU Space Analysis 

1．开始 

¤ 选择菜单中 Start → Digital Mockup → DMU Optimizer（见图 15-1）。 

 

图 15-1 

2．Measures Between 

¤ 显示零件之间 x，y，z 轴方向的最小距离的命令 。 
（1）选择菜单 File → Open  打开文档（必须是装配件）（见图 15-2）； 

 

图 15-2 
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（2）点击  ，Selection 1 mode 栏中用鼠标选盖的上部，Selection 2 mode 栏中用鼠

标选笔的底部，窗口中显示距离和角度（见图 15-3）； 

 

图 15-3 

（3）选择 时，可以显示一个点的坐标，选择 时显示坐标和距离 

3．Sectioning 

¤ 生成切割面的命令  。图 15-3 中点击该键，选择 Volume Cut 时，切除（见图

15-4）。 

 

图 15-4 

4．Detecting Clashed 

¤ 确认零件之间干涉的命令  。图 15-4 中先用鼠标选择盖，然后点击  ，
干涉部分用红色显示（见图 15-5）。 
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第 16 章  Generative Knowledge 

设计三维模型的过程的编程语言，可对尺寸、形象进行修改。 

1．开始 

¤ 选择菜单中 Start → Knowledgeware → Product Knowledge Template（见图

16-1）。 

 

图 16-1 

（1）  菜单中 Tools → Options → Parameters and Measure → Knowledge 中的

Parameter Tree View 设成如图 16-2； 

 

图 16-2 



 

（2）菜单中 Tools → Options → Infrastructure → Part Infrastructure → Display 中

的 Display In Specification Tree 设成如图 16-3。 
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图 16-3 

2．Generative Script Editor 

¤ 生成 Generative Script 的命令  。 
（1）点击  键（见图 16-4）； 

 

图 16-4 

（2）对话框中选择 File → CATPart document，对话框中输入 BoxPart，BoxPart1（见

图 16-5）； 
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图 16-5 

（3）点击 OK 键后，出现编程窗口（可以复制其他.TXT 文档），输入如下内容（见

图 16-6）； 

 

图 16-6 

（4）点击 Generate 键，其效果如图 16-7。 

 

图 16-7 
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* 用模型修改尺寸时（双击模型后进入 Part Design 界面），Generative Script Editor
中的内容不发生变化。相反，在 Generative Script Editor 中修改尺寸时，模型的尺寸也随

之发生变化。 

3．Body 
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¤ Part 中组合多个模型的命令。 
（1）点击  键后，输入如下内容（见图 16-8）； 

 

图 16-8 

（2）点击 Generate 键，其效果见图 16-9。 

 

图 16-9 
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* ObjectName isa objecType， 
* 变更 ObjectName 和 Radius、InnerRadius、SectionRadius 的尺寸。 

4．Chamfer 

¤ 生成倒角的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-10）； 

 

图 16-10 

（2）点击 Generate 键后，出现 Enter inputs 对话框，设 i=0 后点击 Apply，
ChamferRibbon.1\Length1.=1.5mm 后点击 Apply 和 OK 键（见图 16-11，16-12）； 

           

图 16-11                                图 16-12 
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* Chamfer1 isa Chamfer（适用部分）{长度，角}； 
* ChamferRibbon.1\Length1； 
* ChamferRibbon.1\Angle。 
（3）先生成四方体后，鼠标放到 Chamfer1 isa Chamfer，按右键，选择 Get Edge（图

16-13 中暗色部分），在其前面加("Edge:(Face:(Brp:(Box1;，最后加一个括号之后点击

Generate 键。 
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图 16-13 

5．Cone 

¤ 生成圆锥体的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-14）； 

 

图 16-14 
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（2）点击 Generate 键，其效果见图 16-15。 

 

图 16-15 

6．Pad 

¤ 生成厚度的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-16）； 

 

图 16-16 

（2）点击 Generate 键，其效果见图 16-17。 
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 图 16-17 

7．Cylinder 

¤ 生成圆柱的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-18）； 

 

图 16-18 

（2）点击 Generate 键，其效果见图 16-19。 
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图 16-19 

8．Shell 

¤ 生成抽壳的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-20）； 

 

图 16-20 
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（2）点击 Generate 键，其效果见图 16-21。 
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图 16-21 

* Shell1 isa Shell（适用部分）{内部厚度，外部厚度}； 
* InnerThickness，OutsideThickness（基本设为 1mm）。 

6．Torus 

¤ 生成圆环的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-22）； 

 

图 16-22 
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（2）点击 Generate 键，其效果见图 16-23。 

 

图 16-23 

10．Position 

¤ 定义模型之间距离的命令。 
（1）Generative Script Editor 对话框中输入如下内容（见图 16-24）； 

 

图 16-24 
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（2）点击 Generate 键，其效果见图 16-25。 
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图 16-25 
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